Deploying lightning - error after adding asdf lines

hey @taylordowns2000 @stu @rogerio we received the below query from @Kiefer and the os4h team. Can you assist?

I am currently trying to install an OpenFn lightning instance via docker.

I am following this documentation GitHub - OpenFn/lightning: OpenFn/Lightning ⚡️ is the newest version of the OpenFn DPG and provides a web UI to visually manage complex workflow automation projects..

Is there any specific adjustments needed to be made to the .env file before running this command “docker compose run --rm web mix ecto.migrate”. Currently I am getting this error after adding the asdf lines to the ~/.bashrc file.

Any suggestions?

Screenshot 2024-03-28 112228

Here is a screenshot of the error i am getting.

Hey @Kiefer , great to hear from you!

There may be two things going on here—I’ll try to separate them:

  1. We’ve just merged a change to the Docker compose file that means you won’t need to set any specific ENVs if you don’t want. The new compose file has built-in defaults that should work for many people. Check out the “Run via Docker” section of the Getting Started guide for instructions.

  2. I’ve got to admit I’m thrown off by your mention of asdf—so maybe there is something else going on? ASDF is a tool for managing runtime versions and it makes devving, building, and running on directly on Erlang, Elixir, Node, etc. a breeze, but it’s not necessary for running a Lightning image inside Docker. If you are interested in setting up a local environment that’s well suited to building new features in for Lightning, follow the “Dev on Lightning Locally” part of the Getting Started guide.

And thanks for using the forum! Please let me know if either of the above suggestions are helpful and how you get on with the local setup :slight_smile:

1 Like

Hey @taylordowns2000 Following the instructions of “Run Via Docker” metioned in #1 i got the following error.

Attaced is the error and the logs of the docker compose.

Screenshot 2024-04-02 114821

Thanks @Kiefer . That relation ... does not exist looks to me like the migrations haven’t been run. Can you make sure you’re on the latest version? (And maybe paste in your current tagged version? You should be on lightning v2.3.0.)

Docker - latest or v2.3.0 should both do the trick.

@rogerio recently added this commit which should have baked-in the migrations.

1 Like

I got it running sucessfully. I just started fresh by removing all the images and files and went through the “Run Via Docker” instrcutions and it worked.

Thanks for your assistance.


Fantastic. Thanks for the update and thanks @rogerio for the docker setup changes!