Deploying Lightning : Stuck on loading workflows screen

After successfully installing the lighning version locally and creating the project it then freezes on the loading workflows screen. I did an ispection of the page on the front end and thats the response i received.

Thanks @Kiefer . For questions like this, it’s super helpful to know how you’re running your application and some basic information about your environment. Are you running this via mix? Or maybe via Docker?

I’ve never seen that error before, but after punching it into Goolgle the first hit I get mentions NodeJs versions: javascript - NodeJS, crypto.randomUUID is not a function - Stack Overflow

Apologies if you’ve already done this, but without additional information I’d start by reading that post and ensuring that you’re using a NodeJs version that has the crypto.randomUUID function.

Again, sorry if you’ve already done this. Send over some more information and someone from the community might be able to give you some better help.

1 Like

I am running this via docker.

crypto.randomUUID function was added in node version 15.6.0 which i was using. I also updated to versions 20.12.1 & 21.7.2 which gave the same error.

Hi Kiefer,

Thank you for reaching out with the details of the issue you’re encountering in Lightning. To address this effectively and ensure we can get to the bottom of it swiftly, I propose we set up a 30-minute Google Meet call for a live troubleshooting session. During this call, we can explore your setup more closely and navigate through the specifics of the error.

To schedule our session, please use my Calendly link: https://calendly.com/elias-4enq/how-can-i-help-you. Select a time that works best for you, and I’ll be there to assist you.

Looking forward to our collaboration and to resolving this unique challenge together.

1 Like

Hi @Kiefer ,

Thanks for the great call and debugging session earlier. I’m glad we were able to identify the problem and find a solution for it. I want to share this message for others who may encounter the same issue.

The issue you were experiencing with Lightning is due to the crypto.randomUUID function requiring HTTPS to work properly. This is documented here.

In a local development environment (localhost), this isn’t typically a problem because localhost is treated as a secure environment, similar to HTTPS. However, when accessing Lightning without HTTPS in a production environment, this issue arises.

To resolve this, you’ll need to ensure that your server is set up with HTTPS. Once HTTPS is configured, the crypto.randomUUID function should work as expected and then your workflows render nicely.

You mentioned that you could quickly set up HTTPS on your server. That’s great to hear! Please let us know how it goes or if you need any further assistance.

Best regards

1 Like

Hey @elias,

I did setup up HTTPS on my server and got past the error that we discussed. Thanks again for the assistance in quickly resolving this issue.

However upon testing i came across another issue in running a job.


Runing this job(pulling data from a postgres database) i got this error.

@Kiefer in your postgresql credential have you selected Use SSL and Allow self-signed certificate ?

Yes I have selected both Use SSL and Allow self-signed certificate.

@Kiefer can you try unselecting use ssl and run the workflow again ?

If that does not work, un select both use ssl and allow self-signed certificate and try again

Tried both options and neither worked.